aboutsummaryrefslogtreecommitdiffstats
path: root/community/ocaml
diff options
context:
space:
mode:
authorTuan Hoang <tmhoang@linux.ibm.com>2019-11-22 18:42:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-25 07:29:21 +0000
commitda68172df58bbbb6ea94b3f2f569bdf7628a0660 (patch)
tree637da7ab84a7c5983916f861cfd41ad9399979e0 /community/ocaml
parent0af557e86d000ac9a1bc35a99b5d14d417c67d72 (diff)
downloadaports-da68172df58bbbb6ea94b3f2f569bdf7628a0660.tar.bz2
aports-da68172df58bbbb6ea94b3f2f569bdf7628a0660.tar.xz
community/ocaml: fix mcontext patch on s390x
The context patch was just wrong from the beginning. No pkgrel bump.
Diffstat (limited to 'community/ocaml')
-rw-r--r--community/ocaml/APKBUILD4
-rw-r--r--community/ocaml/fix-mcontext-fields.patch17
2 files changed, 2 insertions, 19 deletions
diff --git a/community/ocaml/APKBUILD b/community/ocaml/APKBUILD
index c197c5eee5..e86462ef2b 100644
--- a/community/ocaml/APKBUILD
+++ b/community/ocaml/APKBUILD
@@ -6,7 +6,7 @@ pkgver=4.08.1
pkgrel=1
pkgdesc="Main implementation of the Caml programming language"
url="http://ocaml.org/"
-arch="aarch64 ppc64le x86_64"
+arch="all !x86 !armhf !armv7"
license="LGPL-2.1-or-later-WITH-linking-exception"
depends="$pkgname-runtime=$pkgver-r$pkgrel gcc"
makedepends="gdbm-dev libc-dev ncurses-dev zlib-dev binutils-dev"
@@ -120,6 +120,6 @@ _submv() {
sha512sums="8239c1879926e59c3d9611ad0d97618ce21b0528f1bd59db3df9c24287ad180ffa74f34e52e1fab39e71cbf8113a9a4ee5037cc33ae64ca6a9a109fe4ada0256 ocaml-4.08.1.tar.gz
49cbd6df3a70d00df33d34ab4508dd04d52cbc94efc6c8cac8668758e7346be3c7acedf5b8af38a0adb18c69b8d0859667b12cc11699002c048af962cf283ad2 compile-without-debug-info.patch
-cd0b9a8c3dc8d952a40eb1758cc74dc388ec4bcc5fe5a25c3f073f0088bf51027b53ea1b9f6d02a84b11bd3964bec1c50b5da28caa7c1e31ec76f9930ea7d527 fix-mcontext-fields.patch
+e853f609006bd2514bbf63cf9215150496ec62ceee3e55f6f719b19453c97251ad935245578528fab798e626dab5a6c4e2fd5fb652f99ddd5cfd261ac0c4c9bb fix-mcontext-fields.patch
e65b647427d9c94933d5be97857daf8cdc65e25c10066740dbcbab7a4e6f8ddb2277ee7d5796abf5916e5bdd59b057de736190432c480fc8ff2a4b2a94d46eca fix-segfault-in-ppc64le.patch
b3362906c23ecdb084db7dbf18cae22f0a54ba968f1ecf9c8d13c230ca221b3f77fa820a52e091ce7b71b1cb4a91faf1346692aa6fa411bb46fca784500def25 fix-check-parser-uptodate-or-warn.sh.patch"
diff --git a/community/ocaml/fix-mcontext-fields.patch b/community/ocaml/fix-mcontext-fields.patch
index 436057df76..23b4875d21 100644
--- a/community/ocaml/fix-mcontext-fields.patch
+++ b/community/ocaml/fix-mcontext-fields.patch
@@ -25,20 +25,3 @@ diff -Nru a/runtime/signals_osdep.h b/runtime/signals_osdep.h
+ #endif
/****************** PowerPC, NetBSD */
-
-@@ -354,11 +362,11 @@
- sigact.sa_flags = 0
-
- typedef unsigned long context_reg;
-- #define CONTEXT_PC (context->sregs->regs.psw.addr)
-- #define CONTEXT_EXCEPTION_POINTER (context->sregs->regs.gprs[13])
-- #define CONTEXT_YOUNG_LIMIT (context->sregs->regs.gprs[10])
-- #define CONTEXT_YOUNG_PTR (context->sregs->regs.gprs[11])
-- #define CONTEXT_SP (context->sregs->regs.gprs[15])
-+ #define CONTEXT_PC (context->sregs->psw.addr)
-+ #define CONTEXT_EXCEPTION_POINTER (context->sregs->gregs[13])
-+ #define CONTEXT_YOUNG_LIMIT (context->sregs->gregs[10])
-+ #define CONTEXT_YOUNG_PTR (context->sregs->gregs[11])
-+ #define CONTEXT_SP (context->sregs->gregs[15])
-
- /******************** Default */