aboutsummaryrefslogtreecommitdiffstats
path: root/community/ocamlbuild
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-11 17:16:16 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-11 19:11:20 +0100
commitac17cc599007fef6e71ccc868565bbd811834f4c (patch)
tree7f8092b3eed492e9505771eb53cd45b8fbf7f157 /community/ocamlbuild
parent5749edfd7847e6d0c668eed8e7f9b01eb06100a9 (diff)
downloadaports-ac17cc599007fef6e71ccc868565bbd811834f4c.tar.bz2
aports-ac17cc599007fef6e71ccc868565bbd811834f4c.tar.xz
community/ocamlbuild: run tests
Diffstat (limited to 'community/ocamlbuild')
-rw-r--r--community/ocamlbuild/APKBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/community/ocamlbuild/APKBUILD b/community/ocamlbuild/APKBUILD
index ee4e7e69b3..2c0c358758 100644
--- a/community/ocamlbuild/APKBUILD
+++ b/community/ocamlbuild/APKBUILD
@@ -7,6 +7,7 @@ pkgdesc="Generic build tool with built-in rules for building OCaml library and p
url="https://github.com/ocaml/ocamlbuild"
arch="all !x86 !armhf !s390x" #ocaml not avail on excluded platforms
license="LGPL-2.0-or-later-WITH-linking-exception"
+checkdepends="ocaml-compiler-libs ocaml-findlib"
makedepends="ocaml"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/ocaml/$pkgname/archive/$pkgver.tar.gz"
@@ -21,6 +22,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make test
+}
+
package() {
cd "$builddir"