aboutsummaryrefslogtreecommitdiffstats
path: root/community/ocamlbuild
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-04 23:42:53 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-05 00:14:26 +0100
commitc2ebfdef530dc202a300a15cb5bf2b30ccaa38b7 (patch)
treea2617cbcd26ff6e05c272ee83edfdf7898e49ad2 /community/ocamlbuild
parent303c40761a6cc857c3fdc44681732085f627d8c2 (diff)
downloadaports-c2ebfdef530dc202a300a15cb5bf2b30ccaa38b7.tar.bz2
aports-c2ebfdef530dc202a300a15cb5bf2b30ccaa38b7.tar.xz
community/ocamlbuild: modernize abuild
Diffstat (limited to 'community/ocamlbuild')
-rw-r--r--community/ocamlbuild/APKBUILD16
1 files changed, 5 insertions, 11 deletions
diff --git a/community/ocamlbuild/APKBUILD b/community/ocamlbuild/APKBUILD
index 434f160be3..2dfc6e305c 100644
--- a/community/ocamlbuild/APKBUILD
+++ b/community/ocamlbuild/APKBUILD
@@ -7,22 +7,17 @@ pkgdesc="Generic build tool with built-in rules for building OCaml library and p
url="https://github.com/ocaml/ocamlbuild"
arch="all !x86 !armhf !s390x" #ocaml not avail on excluded platforms
license="LGPL-2.0"
-depends=""
makedepends="ocaml"
-options=""
-install=""
-subpackages=""
-
-source="${pkgname}-${pkgver}.tar.gz::https://github.com/ocaml/ocamlbuild/archive/${pkgver}.tar.gz"
-
+source="$pkgname-$pkgver.tar.gz::https://github.com/ocaml/$pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
+
build() {
cd "$builddir"
make configure OCAML_NATIVE=true \
OCAMLBUILD_BINDIR="/usr/bin" \
- OCAMLBUILD_LIBDIR="/usr/lib/ocaml" || return 1
- make || return 1
+ OCAMLBUILD_LIBDIR="/usr/lib/ocaml"
+ make
}
package() {
@@ -30,6 +25,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="d5ba7ee06a51a3333f2168cd431df4ae ocamlbuild-0.9.3.tar.gz"
-sha256sums="32e4824906888c61244909eab0d2c22d31f18fc9579873a070a4cf7947c2c0a9 ocamlbuild-0.9.3.tar.gz"
+
sha512sums="49ab3a13d48f8f554c85ebc8ce9cbc5a5e63112c2d50215a6f4be78cc21c6e93bd5d657ea45584cfbfa00d182d99adad0fbb706e8121b71ea3ecf4830fd947dd ocamlbuild-0.9.3.tar.gz"