aboutsummaryrefslogtreecommitdiffstats
path: root/community/ocamlbuild
diff options
context:
space:
mode:
authorAnil Madhavapeddy <anil@recoil.org>2016-12-01 18:23:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-12-02 21:20:45 +0000
commitc9ebcfc8f43c84d6e4a85a6a11067ea91aef8078 (patch)
tree72c5443ca4968ff2e768c8667daa10309dfb6043 /community/ocamlbuild
parent801ace687ae3930b8c1bc3cc722aac05e0910f37 (diff)
downloadaports-c9ebcfc8f43c84d6e4a85a6a11067ea91aef8078.tar.bz2
aports-c9ebcfc8f43c84d6e4a85a6a11067ea91aef8078.tar.xz
community/ocamlbuild: move from testing to community
Diffstat (limited to 'community/ocamlbuild')
-rw-r--r--community/ocamlbuild/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/ocamlbuild/APKBUILD b/community/ocamlbuild/APKBUILD
new file mode 100644
index 0000000000..37d35c2e84
--- /dev/null
+++ b/community/ocamlbuild/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Jon Ong <jonongjs@rottenmage.com>
+# Maintainer: Anil Madhavapeddy <anil@recoil.org>
+pkgname=ocamlbuild
+pkgver=0.9.2
+pkgrel=0
+pkgdesc="Generic build tool with built-in rules for building OCaml library and programs."
+url="https://github.com/ocaml/ocamlbuild"
+arch="all !x86"
+license="LGPL2"
+depends=""
+makedepends="ocaml"
+options=""
+install=""
+subpackages=""
+
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/ocaml/ocamlbuild/archive/${pkgver}.tar.gz"
+
+builddir="$srcdir/$pkgname-$pkgver"
+build() {
+ cd "$builddir"
+
+ make configure OCAML_NATIVE=true \
+ OCAMLBUILD_BINDIR="/usr/bin" \
+ OCAMLBUILD_LIBDIR="/usr/lib/ocaml" || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+
+ make DESTDIR="$pkgdir" install
+}
+md5sums="b8c90bac4e54e3b5b8243c4845122dd2 ocamlbuild-0.9.2.tar.gz"
+sha256sums="257a3961da1aa47deb3de8da238ebe1daf13a73efef2228f97a064a90f91c6bc ocamlbuild-0.9.2.tar.gz"
+sha512sums="6f6fa2ca0030256b61a9f93275f26327a032594a1ddd288e1eb9f4c41dfc139e4cdb6cd66ae8e383dd2f8aabb435181abfbf6b4aa0892ef6fa420c29e33b391a ocamlbuild-0.9.2.tar.gz"