aboutsummaryrefslogtreecommitdiffstats
path: root/community/openal-soft
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-27 01:17:22 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-27 01:17:22 -0300
commit262c52e574ff527fdc1ae8453df270bf7365c04c (patch)
tree521fc828900ee8fd0cc53aecb9e8b22b7b032b70 /community/openal-soft
parent56057eb7274804c6d896041a4ba65294708bf7cd (diff)
downloadaports-262c52e574ff527fdc1ae8453df270bf7365c04c.tar.bz2
aports-262c52e574ff527fdc1ae8453df270bf7365c04c.tar.xz
community/openal-soft: fix license
Diffstat (limited to 'community/openal-soft')
-rw-r--r--community/openal-soft/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/community/openal-soft/APKBUILD b/community/openal-soft/APKBUILD
index ca028769ee..8c61c0d7de 100644
--- a/community/openal-soft/APKBUILD
+++ b/community/openal-soft/APKBUILD
@@ -1,12 +1,12 @@
-# Contributor:
+# Contributor:
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=openal-soft
pkgver=1.19.1
-pkgrel=0
+pkgrel=1
pkgdesc="software implementation of OpenAL API"
url="https://kcat.strangesoft.net/openal.html"
arch="all"
-license="LGPL"
+license="LGPL-2.0-or-later"
depends_dev="alsa-lib-dev"
makedepends="$depends_dev linux-headers cmake"
subpackages="$pkgname-dev"
@@ -15,15 +15,14 @@ options="!check"
builddir="${srcdir}/${pkgname}-${pkgver}"
-_builddir="${srcdir}/build"
+builddir="${srcdir}/build"
prepare() {
default_prepare
- mkdir -p "$_builddir"
+ mkdir -p "$builddir"
}
build() {
local _cpuext_neon=
- cd "$_builddir"
case "$CARCH" in
armhf) _cpuext_neon=-DALSOFT_CPUEXT_NEON=OFF;;
esac
@@ -35,7 +34,6 @@ build() {
}
package() {
- cd "$_builddir"
make DESTDIR="$pkgdir" install
}