aboutsummaryrefslogtreecommitdiffstats
path: root/community/openjdk8
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2020-03-01 08:54:52 +0100
committerTBK <tbk@jjtc.eu>2020-03-23 14:33:48 +0100
commit36cdd08faa5a5020c8e74205d40230028e5e51f1 (patch)
tree9595111db7e335c49b48afd31008ec4860986973 /community/openjdk8
parentca52a7a437df1415669cd8bcca6106f9734f9a76 (diff)
downloadaports-36cdd08faa5a5020c8e74205d40230028e5e51f1.tar.bz2
aports-36cdd08faa5a5020c8e74205d40230028e5e51f1.tar.xz
community/openjdk8: remove paxmark
Diffstat (limited to 'community/openjdk8')
-rw-r--r--community/openjdk8/APKBUILD13
-rw-r--r--community/openjdk8/fix-paxmark.patch28
2 files changed, 0 insertions, 41 deletions
diff --git a/community/openjdk8/APKBUILD b/community/openjdk8/APKBUILD
index 0c5c5e002a..37dd68e3fb 100644
--- a/community/openjdk8/APKBUILD
+++ b/community/openjdk8/APKBUILD
@@ -45,7 +45,6 @@ makedepends="
nss-dev
nss-static
openjdk7
- paxmark
pcsc-lite-dev
sed
util-linux
@@ -84,7 +83,6 @@ source="https://icedtea.classpath.org/download/source/icedtea-$_icedteaver.tar.x
langtools-$_dropsver.tar.xz::$_dropsurl/langtools.tar.xz
hotspot-$_dropsver.tar.xz::$_dropsurl/hotspot.tar.xz
nashorn-$_dropsver.tar.xz::$_dropsurl/nashorn.tar.xz
- fix-paxmark.patch
icedtea-hotspot-musl.patch
icedtea-hotspot-musl-ppc.patch
@@ -234,7 +232,6 @@ build() {
--with-jdk-src-zip="$srcdir/jdk-$_dropsver.tar.xz" \
--with-langtools-src-zip="$srcdir/langtools-$_dropsver.tar.xz" \
--with-nashorn-src-zip="$srcdir/nashorn-$_dropsver.tar.xz" \
- --with-pax=paxmark \
--with-jdk-home="$_bootstrap_java_home" \
--with-pkgversion="Alpine $pkgver-r$pkgrel" \
--enable-nss \
@@ -261,9 +258,6 @@ package() {
# running 'java -Xshare:dump'.
rm -f "$pkgdir"/$_jrelib/server/classes.jsa
- # pax mark again (due to fakeroot xattr handling bug)
- ./pax-mark-vm "$pkgdir"/$_java_home true
-
# symlink to shared java cacerts store
rm -f "$pkgdir"/$_java_home/jre/lib/security/cacerts
ln -sf /etc/ssl/certs/java/cacerts \
@@ -308,9 +302,6 @@ jre() {
mkdir -p "$subpkgdir"/$_java_home/$dir
mv "$pkgdir"/$_java_home/$file "$subpkgdir"/$_java_home/$dir
done
-
- # Pax mark again (due to fakeroot xattr handling bug).
- "$builddir"/pax-mark-vm "$subpkgdir"/$_java_home true
}
jrebase() {
@@ -330,9 +321,6 @@ jrebase() {
# Rest of the jre subdir (which were not taken by -jre subpkg).
mv "$pkgdir"/$_java_home/jre "$subpkgdir"/$_java_home/
-
- # Pax mark again (due to fakeroot xattr handling bug).
- "$builddir"/pax-mark-vm "$subpkgdir"/$_java_home true
}
doc() {
@@ -360,7 +348,6 @@ cb7a9f80bd33a33f4eb03b091e6c6d3fb6a450695d0231c378d04878fc03e1574f82045c628993e6
3fcb7d264ff23de8b049b264213b05ee9e9120089eaea989e881c0cddc73a2ef9d01f89f66e7ff23c88d9bc4864824c77894d0291caaf9a2a134d5fae650cc32 langtools-3.15.0.tar.xz
181e9f8d0c083b26a24e6bafe0187e39313a6685f3288d62794c5ec07cb8901b53eba25badc74b367de08b53cd2176df45e184f7a6ccbfab57370e7d3cf388f9 hotspot-3.15.0.tar.xz
6d27137dd80d6363e64ef2c6b3abc60603480e9e7f5b99e06ee546a2cc707b801087ce8cc8d021776f5d2b15b73728f08b2e649c65265ba264655d816921ffe7 nashorn-3.15.0.tar.xz
-1f470432275d5beaa8b4e4352a2f24a4a00593546dc4f3bd857794c89e521e8e6d6abc540762bbd769be3e1e3da058e134dc5dc066d12b9b8a1f0656040a795c fix-paxmark.patch
28709285390a997adbd56ebda42ef718fbc08daf572b8568f484436d255514f9d25f033e3333dff8aa352fc9846057ac5bb42fa955d3e5e44eddc96dc273c07c icedtea-hotspot-musl.patch
e5cf4d70f96fc1e72ae8b97a887adb96092ff36584711cbb8de9d9fa9e859cb8731d638838de0d9591239fc44ffe5c74422d1842bd9f10a0c00dff1627bdeeef icedtea-hotspot-musl-ppc.patch
19459dbb922f5a71cd15b53199481498626a783c24f91d2544d55b7dddd2cdb34a64bbf0226b99548612dd1743af01b3f9ff32c30abbbc90ce727ca2dbbbd1f9 icedtea-hotspot-noagent-musl.patch
diff --git a/community/openjdk8/fix-paxmark.patch b/community/openjdk8/fix-paxmark.patch
deleted file mode 100644
index 2c43014322..0000000000
--- a/community/openjdk8/fix-paxmark.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- icedtea-3.3.0/pax-mark-vm.in.orig 2017-02-09 09:42:32.652307034 +0000
-+++ icedtea-3.3.0/pax-mark-vm.in 2017-02-09 09:43:46.043633914 +0000
-@@ -9,17 +9,15 @@
- }
-
- if test "x@PAX_COMMAND@" != "x"; then
-- if @PAX_COMMAND@ -m "${JDK}"/bin/java; then
- for paxable in `list_paxables "${JDK}"/bin/* "${JDK}"/jre/bin/*`; do
- echo "PaX mark @PAX_COMMAND_ARGS@ ${paxable}"
-- @PAX_COMMAND@ @PAX_COMMAND_ARGS@ "${paxable}"
-+ if ! @PAX_COMMAND@ @PAX_COMMAND_ARGS@ "${paxable}"; then
-+ if test "x${FAIL_ON_ERROR}" = "xtrue"; then
-+ echo "ERROR: Could not apply PaX markings to files in ${JDK}";
-+ exit 1;
-+ else
-+ echo "WARNING: Could not apply PaX markings to files in ${JDK}";
-+ fi
-+ fi
- done
-- else
-- if test "x${FAIL_ON_ERROR}" = "xtrue"; then
-- echo "ERROR: Could not apply PaX markings to files in ${JDK}";
-- exit 1;
-- else
-- echo "WARNING: Could not apply PaX markings to files in ${JDK}";
-- fi
-- fi
- fi