aboutsummaryrefslogtreecommitdiffstats
path: root/community/openvas-scanner/001-cmakelist-fortify.patch
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-18 11:59:23 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-18 11:59:49 +0000
commit20c1f7f2330bfd49f9f8a86203aa49b3e34d41a4 (patch)
tree5dfd8cb78d65085c1f6a43fd01444fa92988a39d /community/openvas-scanner/001-cmakelist-fortify.patch
parent0977a30ac83e81c7cbbbefbf41307ad75d7b7787 (diff)
downloadaports-20c1f7f2330bfd49f9f8a86203aa49b3e34d41a4.tar.bz2
aports-20c1f7f2330bfd49f9f8a86203aa49b3e34d41a4.tar.xz
community/openvas-scanner: moved from testing
Diffstat (limited to 'community/openvas-scanner/001-cmakelist-fortify.patch')
-rw-r--r--community/openvas-scanner/001-cmakelist-fortify.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/community/openvas-scanner/001-cmakelist-fortify.patch b/community/openvas-scanner/001-cmakelist-fortify.patch
new file mode 100644
index 0000000000..e77214f945
--- /dev/null
+++ b/community/openvas-scanner/001-cmakelist-fortify.patch
@@ -0,0 +1,21 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 588f5d8..a98929f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -34,6 +34,7 @@ if (POLICY CMP0005)
+ endif (POLICY CMP0005)
+
+ include (FindPkgConfig)
++include(CheckIncludeFile)
+
+ if (NOT PKG_CONFIG_FOUND)
+ message(FATAL_ERROR "pkg-config executable not found. Aborting.")
+@@ -225,7 +226,7 @@ configure_file (tools/greenbone-nvt-sync.in tools/greenbone-nvt-sync @ONLY)
+
+ ## Program
+
+-set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -D_FORTIFY_SOURCE=2 -fstack-protector -Wl,-z,relro -Wl,-z,now")
++set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector -Wl,-z,relro -Wl,-z,now")
+
+ set (CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -Werror")
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${HARDENING_FLAGS} -Wall -D_BSD_SOURCE -D_ISOC99_SOURCE -D_SVID_SOURCE -D_DEFAULT_SOURCE")