aboutsummaryrefslogtreecommitdiffstats
path: root/community/ospd-ikeprobe
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 15:04:02 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 06:53:28 +0000
commit12d2dd694fa43452ab774a620bfe0a07bce02c81 (patch)
tree93cb52a4c90777fda10583151dc717edf8cb89bc /community/ospd-ikeprobe
parent07ab09605ad374713fc714dddc9fc2a3daa3e323 (diff)
downloadaports-12d2dd694fa43452ab774a620bfe0a07bce02c81.tar.bz2
aports-12d2dd694fa43452ab774a620bfe0a07bce02c81.tar.xz
community/ospd-ikeprobe: moved from testing, now uses only python3
Diffstat (limited to 'community/ospd-ikeprobe')
-rw-r--r--community/ospd-ikeprobe/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/ospd-ikeprobe/APKBUILD b/community/ospd-ikeprobe/APKBUILD
new file mode 100644
index 0000000000..c50836f65f
--- /dev/null
+++ b/community/ospd-ikeprobe/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ospd-ikeprobe
+pkgver=1.0b1
+pkgrel=1
+_pkgid=2204
+pkgdesc="OSP server implementation to allow OpenVAS to remotely control a ikeprobe scanner"
+url="http://www.openvas.org/"
+arch="noarch"
+license="GPL"
+depends="python3 ospd"
+makedepends="cmake python3-dev"
+install=""
+subpackages=""
+source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+
+
+md5sums="97bc6b0953faf1e8883ee43360bf1e38 ospd-ikeprobe-1.0b1.tar.gz"
+sha256sums="86b29210b5c5b674352b8366a83b167c492c92e145a1637d28dd9a8f6a2ecde0 ospd-ikeprobe-1.0b1.tar.gz"
+sha512sums="567b2100ab42d7effe8fb47890a3c05fb7066ef97e29f2c723a3f29fd58addac220a91dda01804e997eec126905d43d59621b7318bfa02487ed789e228fe8660 ospd-ikeprobe-1.0b1.tar.gz"