aboutsummaryrefslogtreecommitdiffstats
path: root/community/ospd-nmap/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-09-05 14:27:58 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-09-05 14:27:58 +0000
commit7f5372039869c885c07844be29bb08d88aa58201 (patch)
treeb56a3ab2b97e42cdef3edff863fb376413a45fe3 /community/ospd-nmap/APKBUILD
parent4e1efd4523532a706d2af48c1a6f6740cb2d2edb (diff)
downloadaports-7f5372039869c885c07844be29bb08d88aa58201.tar.bz2
aports-7f5372039869c885c07844be29bb08d88aa58201.tar.xz
community/ospd-nmap: added check, modernized APKBUILD
Diffstat (limited to 'community/ospd-nmap/APKBUILD')
-rw-r--r--community/ospd-nmap/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/community/ospd-nmap/APKBUILD b/community/ospd-nmap/APKBUILD
index ae7bdcf93b..ede22bc7fe 100644
--- a/community/ospd-nmap/APKBUILD
+++ b/community/ospd-nmap/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=ospd-nmap
pkgver=1.0b1
-pkgrel=2
+pkgrel=3
_pkgid=2218
pkgdesc="OSP server implementation to allow OpenVAS to remotel control nmap port scanner"
url="http://www.openvas.org/"
@@ -10,20 +10,22 @@ arch="noarch"
license="GPL"
depends="python3"
makedepends="cmake python3-dev"
-install=""
-subpackages=""
source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz"
-
builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
}
package() {
cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}