aboutsummaryrefslogtreecommitdiffstats
path: root/community/ospd-ssh-keyscan
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 06:56:47 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 06:56:47 +0000
commite16e49874650da995ec729944c33c0e37123295d (patch)
tree712eea9d37f79f80756974b35ef158f1178e7cee /community/ospd-ssh-keyscan
parent18dd99c79a5dc42ef5658c1970a4c09276dc43ef (diff)
downloadaports-e16e49874650da995ec729944c33c0e37123295d.tar.bz2
aports-e16e49874650da995ec729944c33c0e37123295d.tar.xz
testing/ospd-ssh-keyscan: moved from testing. Now uses only python3
Diffstat (limited to 'community/ospd-ssh-keyscan')
-rw-r--r--community/ospd-ssh-keyscan/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/ospd-ssh-keyscan/APKBUILD b/community/ospd-ssh-keyscan/APKBUILD
new file mode 100644
index 0000000000..0e20388ee0
--- /dev/null
+++ b/community/ospd-ssh-keyscan/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ospd-ssh-keyscan
+pkgver=1.0b1
+pkgrel=1
+_pkgid=2213
+pkgdesc="OSP server implementation to allow OpenVAS to scan ssh keys"
+url="http://openvas.org/"
+arch="noarch"
+license="GPLV2+"
+depends="python3 ospd"
+depends_dev=""
+makedepends="python3-dev py3-paramiko"
+install=""
+subpackages=""
+source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+
+md5sums="e78c2f1c4c5fe316f98637535db8cbdf ospd-ssh-keyscan-1.0b1.tar.gz"
+sha256sums="27a73979722e5ec09579cbf8a37228fc0c2a452597e21547244104d29a98950c ospd-ssh-keyscan-1.0b1.tar.gz"
+sha512sums="510a084ff93e2c6283ef21ea4c439077b15c9ada92f48cd0876fca87d430a4479b5700b536d68322cbcde7a1cc5109993706fae4d29e9ee61a7cb927450e5262 ospd-ssh-keyscan-1.0b1.tar.gz"