aboutsummaryrefslogtreecommitdiffstats
path: root/community/pam-u2f/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-03-01 23:44:33 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 01:25:24 -0300
commita7822f599f69652d53ef104c825db42be2a44044 (patch)
tree939b2b9a71b8fae2a8f73c090184016ed28c3c39 /community/pam-u2f/APKBUILD
parent41c244957b767d47b7fa4baf8f9e3a2c6663b18e (diff)
downloadaports-a7822f599f69652d53ef104c825db42be2a44044.tar.bz2
aports-a7822f599f69652d53ef104c825db42be2a44044.tar.xz
community/pam-u2f: move from testing
Diffstat (limited to 'community/pam-u2f/APKBUILD')
-rw-r--r--community/pam-u2f/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/pam-u2f/APKBUILD b/community/pam-u2f/APKBUILD
new file mode 100644
index 0000000000..5f7ccebd7a
--- /dev/null
+++ b/community/pam-u2f/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=pam-u2f
+pkgver=1.0.8
+pkgrel=0
+pkgdesc="Pluggable Authentication Module (PAM) for U2F"
+url="https://developers.yubico.com/pam-u2f/"
+arch="all !s390x" # Limited by libu2f-server-dev
+license="BSD-2-Clause"
+makedepends="libu2f-server-dev libu2f-host-dev linux-pam-dev"
+options="!check" # need yubikey plugged in on live machine
+subpackages="$pkgname-doc"
+source="https://developers.yubico.com/pam-u2f/Releases/pam_u2f-$pkgver.tar.gz"
+builddir="$srcdir/pam_u2f-$pkgver"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --with-pam-dir=/lib/security
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="0bdbea6307428bbed2af69129af207304f7951418ad7df339563f47d678a2cfe6b80321552382e15771cfc06306fae746521850056376f533c430556d051ad36 pam_u2f-1.0.8.tar.gz"