aboutsummaryrefslogtreecommitdiffstats
path: root/community/patchelf
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-05-03 14:02:39 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-05-03 14:02:39 +0000
commitb267eef65002d891571a439b5c82e903859a1269 (patch)
treee1407b7cfcc9b3f810818fb870da747941755ac8 /community/patchelf
parente7d94305413ea582913331a5620ea58601492db5 (diff)
downloadaports-b267eef65002d891571a439b5c82e903859a1269.tar.bz2
aports-b267eef65002d891571a439b5c82e903859a1269.tar.xz
community/patchelf: fix check()
Diffstat (limited to 'community/patchelf')
-rw-r--r--community/patchelf/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/patchelf/APKBUILD b/community/patchelf/APKBUILD
index a400d60c3d..cd9814b47e 100644
--- a/community/patchelf/APKBUILD
+++ b/community/patchelf/APKBUILD
@@ -1,8 +1,7 @@
-# Contributor:
# Maintainer: Michael Koloberdin <koloberdin@gmail.com>
pkgname=patchelf
pkgver=0.9
-pkgrel=1
+pkgrel=2
pkgdesc="Small utility to modify the dynamic linker and RPATH of ELF executables"
url="https://nixos.org/patchelf.html"
arch="all !aarch64"
@@ -28,6 +27,7 @@ build() {
}
check(){
+ cd "$builddir"
if [ "$CARCH" != "ppc64le" ] ; then
make -C tests -j1 check || return 1
fi