aboutsummaryrefslogtreecommitdiffstats
path: root/community/peek
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-03-01 23:49:14 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 01:26:09 -0300
commit7e1696ff7c9fac97050c0b4582b778bc7e25ccce (patch)
treead512c2c8c9f15adbebd2a69258b736cb6ae6a13 /community/peek
parent1e4f09f914e119b53d73930769fac94a658596c3 (diff)
downloadaports-7e1696ff7c9fac97050c0b4582b778bc7e25ccce.tar.bz2
aports-7e1696ff7c9fac97050c0b4582b778bc7e25ccce.tar.xz
community/peek: move from testing
Diffstat (limited to 'community/peek')
-rw-r--r--community/peek/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/peek/APKBUILD b/community/peek/APKBUILD
new file mode 100644
index 0000000000..f2bd3b05eb
--- /dev/null
+++ b/community/peek/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=peek
+pkgver=1.5.1
+pkgrel=0
+pkgdesc="Simple animated GIF screen recorder with an easy to use interface"
+url="https://github.com/phw/peek"
+arch="all"
+license="GPL-3.0-or-later"
+depends="ffmpeg gst-plugins-good gst-plugins-bad"
+makedepends="meson gtk+3.0-dev gettext-dev vala txt2man keybinder3-dev"
+checkdepends="appstream-glib desktop-file-utils"
+subpackages="$pkgname-lang $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/phw/peek/archive/$pkgver.tar.gz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=plain \
+ -Denable-filechoosernative=true \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="dc25f24b1f5954ff26f399f86bf0a2a9b90c4d63c9cd33fcd44f16e447d23070c04e760c57bdc8a946e699c3038b8ee7afc44ce6daa7030e2f9e6f071be6eae4 peek-1.5.1.tar.gz"