aboutsummaryrefslogtreecommitdiffstats
path: root/community/pekwm
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-24 23:52:55 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-24 23:52:55 -0300
commit931d5d47a3a905f537d0a7a9cee37a3a287c4ef4 (patch)
tree867df7542b5d56ef6f3df2b95e31d5bc8c3c4a36 /community/pekwm
parent01d6ed3325f6e1a9606da492c9156ead274ce8e0 (diff)
downloadaports-931d5d47a3a905f537d0a7a9cee37a3a287c4ef4.tar.bz2
aports-931d5d47a3a905f537d0a7a9cee37a3a287c4ef4.tar.xz
community/pekwm: move from main
Diffstat (limited to 'community/pekwm')
-rw-r--r--community/pekwm/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/pekwm/APKBUILD b/community/pekwm/APKBUILD
new file mode 100644
index 0000000000..ea865f2a8c
--- /dev/null
+++ b/community/pekwm/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=pekwm
+pkgver=0.1.17
+pkgrel=4
+pkgdesc="Fast & Light Window Manager"
+url="https://github.com/pekdon/pekwm"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="libx11-dev libpng-dev libxpm-dev libxrender-dev libxrandr-dev
+ automake autoconf libtool"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/pekdon/pekwm/archive/release-$pkgver.tar.gz"
+builddir="$srcdir/pekwm-release-$pkgver"
+
+prepare() {
+ default_prepare
+ autoreconf -fi
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="1950888402f11c5cd72c9d82de976c472d4a0443da206629a039d19a1729660fd7cd09535d35984d554dcdb366918d9e29536b1272521f36f7e54499df0c14af pekwm-0.1.17.tar.gz"