aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-algorithm-diff/APKBUILD
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2020-04-03 23:59:26 +0000
committerTimothy Legge <timlegge@gmail.com>2020-04-04 13:33:43 +0000
commit605616381dfa5301a86959e34bdde3d2ad188a7a (patch)
tree00c5111150606eccfdb9751d0e5a95e149459e57 /community/perl-algorithm-diff/APKBUILD
parentfdf87ca78a3e4585581cc08fa370a84c03d17cdc (diff)
downloadaports-605616381dfa5301a86959e34bdde3d2ad188a7a.tar.bz2
aports-605616381dfa5301a86959e34bdde3d2ad188a7a.tar.xz
community/perl-algorithm-diff: modernize APKBUILD
Diffstat (limited to 'community/perl-algorithm-diff/APKBUILD')
-rw-r--r--community/perl-algorithm-diff/APKBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/community/perl-algorithm-diff/APKBUILD b/community/perl-algorithm-diff/APKBUILD
index 38b163a75a..8073c84ea7 100644
--- a/community/perl-algorithm-diff/APKBUILD
+++ b/community/perl-algorithm-diff/APKBUILD
@@ -1,31 +1,29 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-algorithm-diff
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Algorithm-Diff
pkgver=1.1903
-pkgrel=2
+pkgrel=3
pkgdesc="Compute 'intelligent' differences between two files / lists"
-url="https://metacpan.org/release/Algorithm-Diff"
+url="https://metacpan.org/release/Algorithm-Diff/"
arch="noarch"
license="GPL-1.0-or-later OR Artistic-1.0-Perl"
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+depends="perl"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/T/TY/TYEMQ/Algorithm-Diff-$pkgver.tar.gz"
-
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- default_prepare
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}