aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-config-simple
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-06 12:11:53 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-06 12:18:06 +0000
commit5fcf9eb2802c57bb047905e3047d391142e52041 (patch)
treecda92d76381d7760edf5ae98c75650d62aca76a9 /community/perl-config-simple
parente5ab1fc88b1ff6b7c01adbb6dccf39b70f6cc16d (diff)
downloadaports-5fcf9eb2802c57bb047905e3047d391142e52041.tar.bz2
aports-5fcf9eb2802c57bb047905e3047d391142e52041.tar.xz
community/perl-c*: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - Rename _builddir to builddir - Add missing default_prepare in prepare()
Diffstat (limited to 'community/perl-config-simple')
-rw-r--r--community/perl-config-simple/APKBUILD35
1 files changed, 20 insertions, 15 deletions
diff --git a/community/perl-config-simple/APKBUILD b/community/perl-config-simple/APKBUILD
index 87d5e91560..19239ed80f 100644
--- a/community/perl-config-simple/APKBUILD
+++ b/community/perl-config-simple/APKBUILD
@@ -4,38 +4,43 @@
pkgname=perl-config-simple
_pkgreal=Config-Simple
pkgver=4.59
-pkgrel=0
-pkgdesc="simple configuration file class"
+pkgrel=1
+pkgdesc="Simple configuration file class"
url="http://search.cpan.org/dist/Config-Simple/"
arch="noarch"
license="GPL PerlArtistic"
cpandepends=""
-cpanmakedepends=" "
+cpanmakedepends=""
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/S/SH/SHERZODR/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ default_prepare
+
+ cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="96513b61c7db591339ce2577878a3b32 Config-Simple-4.59.tar.gz"
-sha256sums="cb78a975ad8463f992f35f392227aaf188d533c9092373742b3c2bb592781054 Config-Simple-4.59.tar.gz"
sha512sums="23eb4f5ace1288c3d2a6105fa109d08e8170f4c1b5f6a28b460bb9e0fb62c66c7d392712fca0c96d83c4a16f5c940fcbc348d700a7bef86bf2ba37cd114c8a14 Config-Simple-4.59.tar.gz"