aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-data-hexdump
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-01-01 17:45:15 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-01-01 17:45:17 +0000
commitccca3236711b56d6ecc58247063a4e4f51c80476 (patch)
treee36f3bc0f90ed33dda3f9f5c5db143eef78d8c3c /community/perl-data-hexdump
parent08c37535977c75460de510b473e579b299a934b0 (diff)
downloadaports-ccca3236711b56d6ecc58247063a4e4f51c80476.tar.bz2
aports-ccca3236711b56d6ecc58247063a4e4f51c80476.tar.xz
community/perl-d*: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - Rename _builddir to builddir - Add missing default_prepare in prepare() - Remove old checksums
Diffstat (limited to 'community/perl-data-hexdump')
-rw-r--r--community/perl-data-hexdump/APKBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/community/perl-data-hexdump/APKBUILD b/community/perl-data-hexdump/APKBUILD
index f0c189beff..a703f4f78b 100644
--- a/community/perl-data-hexdump/APKBUILD
+++ b/community/perl-data-hexdump/APKBUILD
@@ -4,8 +4,8 @@
pkgname=perl-data-hexdump
_pkgreal=Data-HexDump
pkgver=0.02
-pkgrel=0
-pkgdesc="unknown"
+pkgrel=1
+pkgdesc="Hexadecial Dumper"
url="http://search.cpan.org/dist/Data-HexDump/"
arch="noarch"
license="GPL PerlArtistic"
@@ -16,21 +16,28 @@ makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/F/FT/FTASSIN/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ default_prepare
+
+ cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
- make && make test
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}