aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-date-manip
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-06-18 04:03:48 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-18 10:53:41 -0300
commit86b45386da94228b00ded5b55c21699e73e42173 (patch)
tree54aae8ddfc74092414baa4c4b46b9ebe7513ddca /community/perl-date-manip
parentc8d5292fcc124b3cde16a4eb5c94748dfe97b378 (diff)
downloadaports-86b45386da94228b00ded5b55c21699e73e42173.tar.bz2
aports-86b45386da94228b00ded5b55c21699e73e42173.tar.xz
community/perl-date-manip: upgrade to 6.77
Diffstat (limited to 'community/perl-date-manip')
-rw-r--r--community/perl-date-manip/APKBUILD11
-rw-r--r--community/perl-date-manip/test.pl9
2 files changed, 6 insertions, 14 deletions
diff --git a/community/perl-date-manip/APKBUILD b/community/perl-date-manip/APKBUILD
index 6f1916dbaf..9ba45f8728 100644
--- a/community/perl-date-manip/APKBUILD
+++ b/community/perl-date-manip/APKBUILD
@@ -2,18 +2,19 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-date-manip
_pkgreal=Date-Manip
-pkgver=6.76
-pkgrel=1
+pkgver=6.77
+pkgrel=0
pkgdesc="Date manipulation routines"
-url="http://search.cpan.org/dist/Date-Manip/"
+url="https://search.cpan.org/dist/Date-Manip/"
arch="noarch"
license="GPL-1.0-or-later OR Artistic-1.0-Perl"
cpandepends="perl-yaml-syck"
cpanmakedepends="perl-test-inter"
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends perl-module-build"
+checkdepends="perl-test-pod perl-test-pod-coverage perl-file-find-rule"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/S/SB/SBECK/$_pkgreal-$pkgver.tar.gz"
+source="https://search.cpan.org/CPAN/authors/id/S/SB/SBECK/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
@@ -34,4 +35,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="dab6416e58ca5a032bd3e1a7d44578f5fad7ed6c2d9f1f8afdff6e04ecac13ceb035f533ab7f3cdb0875f7916166a51845f49cb8da40775846fb9b27b635e280 Date-Manip-6.76.tar.gz"
+sha512sums="cdcd900b6028eab2d3ac80d2e7b71723ddb6cf1011be78d025568af1340bf408327d58d51491610459aeb0adb7097320436b5f40640ea3aad3afd912de2a1a72 Date-Manip-6.77.tar.gz"
diff --git a/community/perl-date-manip/test.pl b/community/perl-date-manip/test.pl
deleted file mode 100644
index cd78aa14f8..0000000000
--- a/community/perl-date-manip/test.pl
+++ /dev/null
@@ -1,9 +0,0 @@
-use Date::Manip;
-
-$dmt = new Date::Manip::TZ;
-$obj = $dmt->base();
-$dmt->config("forcedate","now,America/New_York");
-
-print $obj->days_since_1BC([1,1,1]),"\n";
-print $obj->days_since_1BC([2,1,1]),"\n";
-