aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-date-manip
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-03 02:07:10 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-05 08:22:26 +0000
commitb9273f6e47d9f11dd716b0e5582d2db087b6ec99 (patch)
tree1412fd74d254be106faa1df5cd3adc62504a323a /community/perl-date-manip
parent56ab4c7e7f3fc86bd686be87d048dc8a1ec840df (diff)
downloadaports-b9273f6e47d9f11dd716b0e5582d2db087b6ec99.tar.bz2
aports-b9273f6e47d9f11dd716b0e5582d2db087b6ec99.tar.xz
community/perl-date-manip: move from main
Diffstat (limited to 'community/perl-date-manip')
-rw-r--r--community/perl-date-manip/APKBUILD41
-rw-r--r--community/perl-date-manip/test.pl9
2 files changed, 50 insertions, 0 deletions
diff --git a/community/perl-date-manip/APKBUILD b/community/perl-date-manip/APKBUILD
new file mode 100644
index 0000000000..5d3b940b73
--- /dev/null
+++ b/community/perl-date-manip/APKBUILD
@@ -0,0 +1,41 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-date-manip
+_pkgreal=Date-Manip
+pkgver=6.76
+pkgrel=0
+pkgdesc="Date manipulation routines"
+url="http://search.cpan.org/dist/Date-Manip/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+cpandepends="perl-yaml-syck"
+cpanmakedepends="perl-test-inter"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends perl-module-build"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/S/SB/SBECK/$_pkgreal-$pkgver.tar.gz"
+
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" pure_install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="dab6416e58ca5a032bd3e1a7d44578f5fad7ed6c2d9f1f8afdff6e04ecac13ceb035f533ab7f3cdb0875f7916166a51845f49cb8da40775846fb9b27b635e280 Date-Manip-6.76.tar.gz"
diff --git a/community/perl-date-manip/test.pl b/community/perl-date-manip/test.pl
new file mode 100644
index 0000000000..cd78aa14f8
--- /dev/null
+++ b/community/perl-date-manip/test.pl
@@ -0,0 +1,9 @@
+use Date::Manip;
+
+$dmt = new Date::Manip::TZ;
+$obj = $dmt->base();
+$dmt->config("forcedate","now,America/New_York");
+
+print $obj->days_since_1BC([1,1,1]),"\n";
+print $obj->days_since_1BC([2,1,1]),"\n";
+