aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-dbix-contextualfetch
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-01-01 17:45:15 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-01-01 17:45:17 +0000
commitccca3236711b56d6ecc58247063a4e4f51c80476 (patch)
treee36f3bc0f90ed33dda3f9f5c5db143eef78d8c3c /community/perl-dbix-contextualfetch
parent08c37535977c75460de510b473e579b299a934b0 (diff)
downloadaports-ccca3236711b56d6ecc58247063a4e4f51c80476.tar.bz2
aports-ccca3236711b56d6ecc58247063a4e4f51c80476.tar.xz
community/perl-d*: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - Rename _builddir to builddir - Add missing default_prepare in prepare() - Remove old checksums
Diffstat (limited to 'community/perl-dbix-contextualfetch')
-rw-r--r--community/perl-dbix-contextualfetch/APKBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/community/perl-dbix-contextualfetch/APKBUILD b/community/perl-dbix-contextualfetch/APKBUILD
index 6ed3340e01..b83c459fb5 100644
--- a/community/perl-dbix-contextualfetch/APKBUILD
+++ b/community/perl-dbix-contextualfetch/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-dbix-contextualfetch
_pkgreal=DBIx-ContextualFetch
pkgver=1.03
-pkgrel=0
+pkgrel=1
pkgdesc="Add contextual fetches to DBI"
url="http://search.cpan.org/dist/DBIx-ContextualFetch/"
arch="noarch"
@@ -16,21 +16,26 @@ makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/T/TM/TMTM/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
- make && make test
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}