aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-dir-self
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-11-23 08:31:47 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-11-23 08:31:47 +0000
commit68109293349d7fcc5e1127c3a3ac68502864bcaf (patch)
tree534d194bd2bb03e3009ca420f713edfad02c161c /community/perl-dir-self
parent49288ea6473e69a848b19f49fac6e8d4059a7260 (diff)
downloadaports-68109293349d7fcc5e1127c3a3ac68502864bcaf.tar.bz2
aports-68109293349d7fcc5e1127c3a3ac68502864bcaf.tar.xz
community/perl-dir-self: moved from testing
Diffstat (limited to 'community/perl-dir-self')
-rw-r--r--community/perl-dir-self/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/perl-dir-self/APKBUILD b/community/perl-dir-self/APKBUILD
new file mode 100644
index 0000000000..93e2620a95
--- /dev/null
+++ b/community/perl-dir-self/APKBUILD
@@ -0,0 +1,41 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Nathan Johnson <nathan@nathanjohnson.info>
+# Maintainer: Nathan Johnson <nathan@nathanjohnson.info>
+pkgname=perl-dir-self
+_pkgreal=Dir-Self
+pkgver=0.11
+pkgrel=0
+pkgdesc="a __DIR__ constant for the directory your source file is in"
+url="http://search.cpan.org/dist/Dir-Self/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/M/MA/MAUKE/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="e484446c3aa042737c0b7cbd0fb2f904 Dir-Self-0.11.tar.gz"
+sha256sums="e251a51abc7d9ba3e708f73c2aa208e09d47a0c528d6254710fa78cc8d6885b5 Dir-Self-0.11.tar.gz"
+sha512sums="c2795149e74c71037fab8c3149e85e11d4ee77dbb54f85d07e49c39504b3ba910a5ded32831adf36915b302abc4ced386dcd51b6dfbaef46e069c803793e8efc Dir-Self-0.11.tar.gz"