aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-file-basedir
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-23 17:27:01 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-23 17:27:03 +0000
commit62750af0fedc04e43d6393aecd7d3d440a2ea2c5 (patch)
tree3acb0a814ae12a564b3df640e66e7fd66da12a83 /community/perl-file-basedir
parent826feb495ee579cc205840c86feb60a363cd72ff (diff)
downloadaports-62750af0fedc04e43d6393aecd7d3d440a2ea2c5.tar.bz2
aports-62750af0fedc04e43d6393aecd7d3d440a2ea2c5.tar.xz
community/perl-[e-f]*: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - Rename _builddir to builddir - Add missing default_prepare in prepare()
Diffstat (limited to 'community/perl-file-basedir')
-rw-r--r--community/perl-file-basedir/APKBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/community/perl-file-basedir/APKBUILD b/community/perl-file-basedir/APKBUILD
index c45f6f14d5..2c2ab475c8 100644
--- a/community/perl-file-basedir/APKBUILD
+++ b/community/perl-file-basedir/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-file-basedir
_pkgreal=File-BaseDir
pkgver=0.07
-pkgrel=0
+pkgrel=1
pkgdesc="Use the Freedesktop.org base directory specification"
url="http://search.cpan.org/dist/File-BaseDir/"
arch="noarch"
@@ -16,26 +16,31 @@ makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/K/KI/KIMRYAN/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ default_prepare
+
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- perl Build.PL installdirs=vendor || return 1
+ perl Build.PL installdirs=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- ./Build && ./Build test
+ ./Build
+}
+
+check() {
+ cd "$builddir"
+ ./Build test
}
package() {
- cd "$_builddir"
- ./Build install destdir="$pkgdir" || return 1
+ cd "$builddir"
+ ./Build install destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="5d10401970d209049c8491d2906c3e13 File-BaseDir-0.07.tar.gz"
-sha256sums="120a57ef78535e13e1465717b4056aff4ce69af1e31c67c65d1177a52169082b File-BaseDir-0.07.tar.gz"
sha512sums="782ed883f37aeb28c4c71a10108865b2cc152c2a7a6015f84cf775be452493a3f599182d213a934e48bd64ffc74369bea61ad89f26f8b7b0c2f94504f107b35d File-BaseDir-0.07.tar.gz"