aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-file-slurper
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-11-16 18:15:26 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-11-16 18:15:26 +0000
commit61598806c9d6cbf2fe54d6e869a17af0b70d5942 (patch)
treeb8a4e24500f8b9beddcad7544d59f37a7d700360 /community/perl-file-slurper
parenta8c1e56979e5f3c606d506aee938a53fac090d90 (diff)
downloadaports-61598806c9d6cbf2fe54d6e869a17af0b70d5942.tar.bz2
aports-61598806c9d6cbf2fe54d6e869a17af0b70d5942.tar.xz
community/perl-file-slurper: moved from testing, as depenedency of biber
Diffstat (limited to 'community/perl-file-slurper')
-rw-r--r--community/perl-file-slurper/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/community/perl-file-slurper/APKBUILD b/community/perl-file-slurper/APKBUILD
new file mode 100644
index 0000000000..6c57db0dcd
--- /dev/null
+++ b/community/perl-file-slurper/APKBUILD
@@ -0,0 +1,48 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=perl-file-slurper
+_pkgreal=File-Slurper
+pkgver=0.009
+pkgrel=1
+pkgdesc="A simple, sane and efficient module to slurp a file"
+url="http://search.cpan.org/dist/File-Slurper/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=""
+cpancheckdepends="perl-test-warnings"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+checkdepends="$cpancheckdepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/L/LE/LEONT/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+check() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+sha512sums="e07074eb5470df75c43848d9bd2e0c5d3bfabf3b6f9739e67d830ce87f4f38a3a569aeca885537d0f9c7d2e285e52f7dfdc27f8035ce0d74d6c750067959f057 File-Slurper-0.009.tar.gz"