aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-functional-utility
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-23 17:27:01 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-23 17:27:03 +0000
commit62750af0fedc04e43d6393aecd7d3d440a2ea2c5 (patch)
tree3acb0a814ae12a564b3df640e66e7fd66da12a83 /community/perl-functional-utility
parent826feb495ee579cc205840c86feb60a363cd72ff (diff)
downloadaports-62750af0fedc04e43d6393aecd7d3d440a2ea2c5.tar.bz2
aports-62750af0fedc04e43d6393aecd7d3d440a2ea2c5.tar.xz
community/perl-[e-f]*: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - Rename _builddir to builddir - Add missing default_prepare in prepare()
Diffstat (limited to 'community/perl-functional-utility')
-rw-r--r--community/perl-functional-utility/APKBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/community/perl-functional-utility/APKBUILD b/community/perl-functional-utility/APKBUILD
index 2766efe4fb..fac05900e5 100644
--- a/community/perl-functional-utility/APKBUILD
+++ b/community/perl-functional-utility/APKBUILD
@@ -3,38 +3,43 @@
pkgname=perl-functional-utility
_pkgreal=Functional-Utility
pkgver=1.02
-pkgrel=0
-pkgdesc="helper tools for light-weight functional programming."
+pkgrel=1
+pkgdesc="Helper tools for light-weight functional programming."
url="http://search.cpan.org/dist/Functional-Utility/"
arch="noarch"
license="GPL PerlArtistic"
cpandepends=""
-cpanmakedepends=" "
+cpanmakedepends=""
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/B/BE/BELDEN/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ default_prepare
+
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="75fc2f5cb6d23d5412fe4ff3a6d54f85 Functional-Utility-1.02.tar.gz"
-sha256sums="1ee089bc0d522bfd6a530eec815233ecb81778f8a576b9733430dc9c4e734104 Functional-Utility-1.02.tar.gz"
sha512sums="bd6945baeef8b35466238c655ec8e7384e087ebfdc565119dc142987feb5affc6c0a85a879f47ff1508f7e0db705ca5a3f9a08d6b09164fa432b4b7c34b04ed1 Functional-Utility-1.02.tar.gz"