aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-math-pari/APKBUILD
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2020-03-22 18:56:57 +0000
committerAriadne Conill <ariadne@dereferenced.org>2020-03-23 00:05:37 +0000
commit645c3d0c8be0de430d3d322d17770c09dddcbc36 (patch)
tree1ab7c481dc8ccb7cdabde91a21a41eeaa0ef923a /community/perl-math-pari/APKBUILD
parent221589c37ab1e70975d2731e3df80265b64be56f (diff)
downloadaports-645c3d0c8be0de430d3d322d17770c09dddcbc36.tar.bz2
aports-645c3d0c8be0de430d3d322d17770c09dddcbc36.tar.xz
community/perl-math-pari: move from testing
Diffstat (limited to 'community/perl-math-pari/APKBUILD')
-rw-r--r--community/perl-math-pari/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/perl-math-pari/APKBUILD b/community/perl-math-pari/APKBUILD
new file mode 100644
index 0000000000..24aea4b00e
--- /dev/null
+++ b/community/perl-math-pari/APKBUILD
@@ -0,0 +1,33 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-math-pari
+_pkgreal=Math-Pari
+pkgver=2.030518
+pkgrel=0
+pkgdesc="Perl interface to PARI."
+url="https://metacpan.org/release/Math-Pari/"
+arch="all !s390x" #Tests do not work on S390
+license="GPL-2.0-or-later OR Artistic-1.0-Perl"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/I/IL/ILYAZ/modules/Math-Pari-$pkgver.zip"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="9bb5d789b5789b38c1d2f07b400f394f8b94872321e9b4de8177e0546fde5f13c277a268f707fbd4c35b336d5f1f86c62744e8a8d0a7d54acece89f1125a89a2 Math-Pari-2.030518.zip"