aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-metacpan-client
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2020-03-23 01:56:52 +0000
committerTimothy Legge <timlegge@gmail.com>2020-03-27 00:38:24 +0000
commit38dfa4fd72b2715b05e890083f8aafae1c027b17 (patch)
tree650afa72f04286c56d7b1ca7a28a49f5fbd1e657 /community/perl-metacpan-client
parent34eb6b89df46d6c8262c91babfe1a75beae267a7 (diff)
downloadaports-38dfa4fd72b2715b05e890083f8aafae1c027b17.tar.bz2
aports-38dfa4fd72b2715b05e890083f8aafae1c027b17.tar.xz
community/perl-metacpan-client: move from testing and modernize
Diffstat (limited to 'community/perl-metacpan-client')
-rw-r--r--community/perl-metacpan-client/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/perl-metacpan-client/APKBUILD b/community/perl-metacpan-client/APKBUILD
new file mode 100644
index 0000000000..0c5906a15e
--- /dev/null
+++ b/community/perl-metacpan-client/APKBUILD
@@ -0,0 +1,36 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-metacpan-client
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=MetaCPAN-Client
+pkgver=2.026000
+pkgrel=0
+pkgdesc="A comprehensive, DWIM-featured client to the MetaCPAN API"
+url="https://metacpan.org/release/MetaCPAN-Client/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl perl-net-ssleay perl-type-tiny perl-moo perl-moo perl-json-maybexs perl-safe-isa perl-io-socket-ssl perl-ref-util perl-uri"
+makedepends="perl-dev"
+checkdepends="perl-www-mechanize-cached perl-http-tiny-mech perl-lwp-protocol-https perl-test-needs perl-test-fatal"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/M/MI/MICKEY/MetaCPAN-Client-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="982207bf8acbc816443c3c4a00a6111735ae694e3644e3644d4ddec80c9e79293ae587a561516f3aa0e59c526840a93118703814b5d199925f4301c297083f09 MetaCPAN-Client-2.026000.tar.gz"