aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-mime-construct
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-12 01:52:06 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-12 01:52:07 +0000
commit2f5f42d4e2a823ef6018afb79d0263bce15e7a48 (patch)
tree21114a47a85db748fd02ce87ec3afd34a208f92e /community/perl-mime-construct
parent8697abb4b2d4e0090ebf23d3b6cd80b7ef2994bc (diff)
downloadaports-2f5f42d4e2a823ef6018afb79d0263bce15e7a48.tar.bz2
aports-2f5f42d4e2a823ef6018afb79d0263bce15e7a48.tar.xz
community/perl-[l-m]*: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - rename _builddir to builddir - add missing default_prepare in prepare()
Diffstat (limited to 'community/perl-mime-construct')
-rw-r--r--community/perl-mime-construct/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/community/perl-mime-construct/APKBUILD b/community/perl-mime-construct/APKBUILD
index 0e0750aba9..b6c8459edc 100644
--- a/community/perl-mime-construct/APKBUILD
+++ b/community/perl-mime-construct/APKBUILD
@@ -3,7 +3,7 @@
pkgname=perl-mime-construct
_pkgreal=mime-construct
pkgver=1.11
-pkgrel=3
+pkgrel=4
pkgdesc="Construct and optionally mail MIME messages"
url="http://search.cpan.org/~rosch/mime-construct/mime-construct"
arch="noarch"
@@ -17,7 +17,7 @@ builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
cd "$builddir"
- default_prepare || return 1
+ default_prepare
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
@@ -25,14 +25,18 @@ prepare() {
build() {
cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="73834ea780fbea81b89dbd9b2fb54f58 mime-construct-1.11.tar.gz"
-sha256sums="4cd7bb61b51d41192d1498c1051aa6a4ccd75aeb09b71d2ec706a7084a4a9303 mime-construct-1.11.tar.gz"
+
sha512sums="1192c5a0cd1c7675aaf4d1570c910672d3c3b6585f33e4781de289e8e1d9530c17b6d48083ad68349b46faa8e03be1dfeef16701b12763adc36bfa4f3b399a5f mime-construct-1.11.tar.gz"