aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-module-implementation
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-12 01:52:06 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-12 01:52:07 +0000
commit2f5f42d4e2a823ef6018afb79d0263bce15e7a48 (patch)
tree21114a47a85db748fd02ce87ec3afd34a208f92e /community/perl-module-implementation
parent8697abb4b2d4e0090ebf23d3b6cd80b7ef2994bc (diff)
downloadaports-2f5f42d4e2a823ef6018afb79d0263bce15e7a48.tar.bz2
aports-2f5f42d4e2a823ef6018afb79d0263bce15e7a48.tar.xz
community/perl-[l-m]*: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - rename _builddir to builddir - add missing default_prepare in prepare()
Diffstat (limited to 'community/perl-module-implementation')
-rw-r--r--community/perl-module-implementation/APKBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/community/perl-module-implementation/APKBUILD b/community/perl-module-implementation/APKBUILD
index 678721f38b..bc697ccde2 100644
--- a/community/perl-module-implementation/APKBUILD
+++ b/community/perl-module-implementation/APKBUILD
@@ -4,38 +4,43 @@
pkgname=perl-module-implementation
_pkgreal=Module-Implementation
pkgver=0.09
-pkgrel=0
+pkgrel=1
pkgdesc="Loads one of several alternate underlying implementations for a module"
url="http://search.cpan.org/dist/Module-Implementation/"
arch="noarch"
license="Artistic-2"
cpandepends="perl-module-runtime perl-try-tiny perl-test-taint"
-cpanmakedepends=" perl-test-fatal perl-test-requires "
+cpanmakedepends="perl-test-fatal perl-test-requires "
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ default_prepare
+
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="52e3fe0ca6b1eff0488d59b7aacc0667 Module-Implementation-0.09.tar.gz"
-sha256sums="c15f1a12f0c2130c9efff3c2e1afe5887b08ccd033bd132186d1e7d5087fd66d Module-Implementation-0.09.tar.gz"
sha512sums="049f967ba1bd8a3914968b34006030ae318d99ac629a0f34736f1c2b5392490c30aa0914e777eaefda7f0f58755d2d3363a266b90db59b53fe145ef68e1d953c Module-Implementation-0.09.tar.gz"