aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-parallel-prefork
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-06-30 15:23:54 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-06-30 15:23:54 +0000
commit9072fa256a6f8259a8c83f70c8afa676c612c79a (patch)
treefc286b2d8cab5d7bfe46b117dac7da68c176f726 /community/perl-parallel-prefork
parentd1a0591917268a5543d8faea0c530c7b4470f3aa (diff)
downloadaports-9072fa256a6f8259a8c83f70c8afa676c612c79a.tar.bz2
aports-9072fa256a6f8259a8c83f70c8afa676c612c79a.tar.xz
community/perl-parallel-prefork: fix build, modernize APKBUILD, add check
Diffstat (limited to 'community/perl-parallel-prefork')
-rw-r--r--community/perl-parallel-prefork/APKBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/community/perl-parallel-prefork/APKBUILD b/community/perl-parallel-prefork/APKBUILD
index 58a83c17fb..27ac5a08fd 100644
--- a/community/perl-parallel-prefork/APKBUILD
+++ b/community/perl-parallel-prefork/APKBUILD
@@ -4,33 +4,37 @@
pkgname=perl-parallel-prefork
_pkgreal=Parallel-Prefork
pkgver=0.14
-pkgrel=0
+pkgrel=1
pkgdesc="A simple prefork server framework"
url="http://search.cpan.org/dist/Parallel-Prefork/"
arch="noarch"
license="GPL PerlArtistic"
cpandepends="perl-list-moreutils perl-class-accessor-lite perl-scope-guard perl-proc-wait3"
-cpanmakedepends="perl-test-sharedfork perl-test-requires "
+cpanmakedepends="perl-test-sharedfork perl-test-requires perl-module-install"
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/K/KA/KAZUHO/$_pkgreal-$pkgver.tar.gz"
-
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
- make && make test
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}