aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-sub-quote
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-07-06 11:07:11 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-07-06 11:31:38 +0000
commite4e1a7a0b1da7c06da1e2080e3d5edf8d60b1344 (patch)
tree757a5fbe9073d9f0c9709c08037dc1760550a0f6 /community/perl-sub-quote
parentc930c29f44d1c8c27a01acc3e871b48922d3b620 (diff)
downloadaports-e4e1a7a0b1da7c06da1e2080e3d5edf8d60b1344.tar.bz2
aports-e4e1a7a0b1da7c06da1e2080e3d5edf8d60b1344.tar.xz
community/perl-sub-quote: new aport (split from perl-moo)
Efficient generation of subroutines via string eval http://search.cpan.org/dist/Sub-Quote/
Diffstat (limited to 'community/perl-sub-quote')
-rw-r--r--community/perl-sub-quote/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/community/perl-sub-quote/APKBUILD b/community/perl-sub-quote/APKBUILD
new file mode 100644
index 0000000000..fa8bf85a01
--- /dev/null
+++ b/community/perl-sub-quote/APKBUILD
@@ -0,0 +1,48 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=perl-sub-quote
+_pkgreal=Sub-Quote
+pkgver=2.004000
+pkgrel=0
+pkgdesc="Efficient generation of subroutines via string eval"
+url="http://search.cpan.org/dist/Sub-Quote/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=""
+cpancheckdepends="perl-test-fatal"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+checkdepends="$cpancheckdepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/H/HA/HAARG/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+check() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+sha512sums="222354896728154da7bfc6ef9d4562430ab250b1e1169330f63b43eef01527785c1c8559c5eb77a8d42484187be74a9ff97b325bb2404a205a6d4b990f8656c5 Sub-Quote-2.004000.tar.gz"