aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-term-animation
diff options
context:
space:
mode:
authoralpterry <alpterry@protonmail.com>2020-02-02 18:26:14 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-02-02 18:39:26 +0100
commit1185aeff48cef1da6f2ee66c9ab6bfd3e3b00223 (patch)
tree8d9523842a6b06c75fe0cc51cd19818159baa62b /community/perl-term-animation
parent49d4ce3285abf878f4265e7b8da2438f3150d73d (diff)
downloadaports-1185aeff48cef1da6f2ee66c9ab6bfd3e3b00223.tar.bz2
aports-1185aeff48cef1da6f2ee66c9ab6bfd3e3b00223.tar.xz
community/perl-term-animation: move from testing
Diffstat (limited to 'community/perl-term-animation')
-rw-r--r--community/perl-term-animation/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/perl-term-animation/APKBUILD b/community/perl-term-animation/APKBUILD
new file mode 100644
index 0000000000..babcc83ef5
--- /dev/null
+++ b/community/perl-term-animation/APKBUILD
@@ -0,0 +1,34 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: alpterry <alpterry@protonmail.com>
+# Maintainer: alpterry <alpterry@protonmail.com>
+pkgname=perl-term-animation
+_pkgreal=Term-Animation
+pkgver=2.6
+pkgrel=0
+pkgdesc="ASCII sprite animation framework"
+url="https://metacpan.org/release/Term-Animation/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl-curses"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/K/KB/KBAUCOM/Term-Animation-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="5d2c3e18e70d19fead2a2ad2d09bfb03f3f3d569f472ea43449799c089254a14ee9c4e695d5c93bda2a30d6e7538566c16a522ceac3c747a5cf0e522f21f1e18 Term-Animation-2.6.tar.gz"