aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-test-class
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2020-03-23 00:55:14 +0000
committerRasmus Thomsen <oss@cogitri.dev>2020-03-23 09:47:46 +0000
commitcd2ac3ec978c4dbc58a45a024c9d7f08a273a758 (patch)
tree44b725cc5dbc414b4a56e0238a7a17a4b87cc539 /community/perl-test-class
parentff92bd14c514acc3177216b571a5932f89f6bae7 (diff)
downloadaports-cd2ac3ec978c4dbc58a45a024c9d7f08a273a758.tar.bz2
aports-cd2ac3ec978c4dbc58a45a024c9d7f08a273a758.tar.xz
community/perl-test-class: move from testing and modernize
Diffstat (limited to 'community/perl-test-class')
-rw-r--r--community/perl-test-class/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/perl-test-class/APKBUILD b/community/perl-test-class/APKBUILD
new file mode 100644
index 0000000000..ca3f6f3aca
--- /dev/null
+++ b/community/perl-test-class/APKBUILD
@@ -0,0 +1,36 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Nathan Johnson <nathan@nathanjohnson.info>
+# Maintainer: Nathan Johnson <nathan@nathanjohnson.info>
+pkgname=perl-test-class
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=Test-Class
+pkgver=0.50
+pkgrel=2
+pkgdesc="Easily create test classes in an xUnit/JUnit style"
+url="https://metacpan.org/release/Test-Class/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl perl-module-runtime perl-mro-compat perl-try-tiny"
+makedepends="perl-dev"
+checkdepends="perl-test-exception"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/E/ET/ETHER/Test-Class-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="27ae19f60a916f5a23cccdc02ff6168e76d5f1cee5df196df4fe50024f7270ee9eaffdf02e9b6de70565c9b6b30606ad0a30477ac8951164b87c641caf960dcc Test-Class-0.50.tar.gz"