aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-test-resub
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 01:16:36 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 01:39:35 +0000
commitb1274f164d3742fc5a47f4ab85a91baef72338ec (patch)
tree7095e084822242b5cff89ac35bb3dee624642067 /community/perl-test-resub
parent4c6f8e1fdf89d2899b81dd6a680a65e89e20b7a9 (diff)
downloadaports-b1274f164d3742fc5a47f4ab85a91baef72338ec.tar.bz2
aports-b1274f164d3742fc5a47f4ab85a91baef72338ec.tar.xz
community/perl-[t-y]: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - rename _builddir to builddir
Diffstat (limited to 'community/perl-test-resub')
-rw-r--r--community/perl-test-resub/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/community/perl-test-resub/APKBUILD b/community/perl-test-resub/APKBUILD
index aa9886d4fc..922410fc37 100644
--- a/community/perl-test-resub/APKBUILD
+++ b/community/perl-test-resub/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-test-resub
_pkgreal=Test-Resub
pkgver=2.03
-pkgrel=0
+pkgrel=1
pkgdesc="Lexically scoped monkey patching for testing"
url="http://search.cpan.org/dist/Test-Resub/"
arch="noarch"
@@ -16,26 +16,29 @@ makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/K/KO/KOLYA/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="8af92b5ec6f3275c88f1a17616d8e8ae Test-Resub-2.03.tar.gz"
-sha256sums="5bc04e7ff90b01c8677b0c3ddaf1be9382c6ace55ab25b0f72e3f935e570da52 Test-Resub-2.03.tar.gz"
sha512sums="f8f5a51adc21296ee7902f029a1aeaf6c34d2c9ced908dad7ffe09b7256d05d222429aab47d5138e7b733456218441a4ea106e16968267ee3b4ad36850244c68 Test-Resub-2.03.tar.gz"