aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-test-taint
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 09:01:56 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 11:24:36 +0000
commit87ae08edc4c89b1d4fb785c483ac01c7db005754 (patch)
treee6511c9fdb65dc3a1f72812bc87aa4625e63f700 /community/perl-test-taint
parent4801e861fa2fc916757983ad749fa1bc40de110a (diff)
downloadaports-87ae08edc4c89b1d4fb785c483ac01c7db005754.tar.bz2
aports-87ae08edc4c89b1d4fb785c483ac01c7db005754.tar.xz
community/perl-test-taint: moved from testing
Diffstat (limited to 'community/perl-test-taint')
-rw-r--r--community/perl-test-taint/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/perl-test-taint/APKBUILD b/community/perl-test-taint/APKBUILD
new file mode 100644
index 0000000000..faea6b51b4
--- /dev/null
+++ b/community/perl-test-taint/APKBUILD
@@ -0,0 +1,41 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=perl-test-taint
+_pkgreal=Test-Taint
+pkgver=1.06
+pkgrel=3
+pkgdesc="Checks for taintedness of variables"
+url="http://search.cpan.org/dist/Test-Taint/"
+arch="all"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends="perl-test-pod perl-test-pod-coverage"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/P/PE/PETDANCE/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="cb639c250f2030262a562ce3376219b0 Test-Taint-1.06.tar.gz"
+sha256sums="721b51ca91d248ea5ff4f99ca49c05a080e6f0fc9f7983e96121b7775ab93107 Test-Taint-1.06.tar.gz"
+sha512sums="58221b0145d9b908994c093168ca547a18cd56113f4923a4662bb9c113635378740363914d1fd43602f15c76a23cfe26d0682ed6ce22836d712692f439e782c2 Test-Taint-1.06.tar.gz"