aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-test-yaml/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-27 20:37:41 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-27 20:37:41 +0100
commitf947a4ce545f86c654464ba4909329a9e156c4a5 (patch)
tree93dbaad72837149672f11349626dcecdbe3b10f7 /community/perl-test-yaml/APKBUILD
parent12021b9af8ba5f272bf3430662912f0df83db5b9 (diff)
downloadaports-f947a4ce545f86c654464ba4909329a9e156c4a5.tar.bz2
aports-f947a4ce545f86c654464ba4909329a9e156c4a5.tar.xz
community/perl-test-yaml: modernize
Diffstat (limited to 'community/perl-test-yaml/APKBUILD')
-rw-r--r--community/perl-test-yaml/APKBUILD22
1 files changed, 8 insertions, 14 deletions
diff --git a/community/perl-test-yaml/APKBUILD b/community/perl-test-yaml/APKBUILD
index 4bfde02b59..1a6ddc8fc1 100644
--- a/community/perl-test-yaml/APKBUILD
+++ b/community/perl-test-yaml/APKBUILD
@@ -4,41 +4,35 @@
pkgname=perl-test-yaml
_pkgreal=Test-YAML
pkgver=1.07
-pkgrel=0
+pkgrel=1
pkgdesc="Testing Module for YAML Implementations"
-url="http://search.cpan.org/dist/Test-YAML/"
+url="https://metacpan.org/release/Test-YAML"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends="perl-test-base"
-cpanmakedepends=" "
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl-test-base"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/T/TI/TINITA/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/T/TI/TINITA/Test-YAML-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
default_prepare
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}
check() {
- cd "$builddir"
- make test
+ make test
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}