aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-test-yaml
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 01:16:36 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 01:39:35 +0000
commitb1274f164d3742fc5a47f4ab85a91baef72338ec (patch)
tree7095e084822242b5cff89ac35bb3dee624642067 /community/perl-test-yaml
parent4c6f8e1fdf89d2899b81dd6a680a65e89e20b7a9 (diff)
downloadaports-b1274f164d3742fc5a47f4ab85a91baef72338ec.tar.bz2
aports-b1274f164d3742fc5a47f4ab85a91baef72338ec.tar.xz
community/perl-[t-y]: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - rename _builddir to builddir
Diffstat (limited to 'community/perl-test-yaml')
-rw-r--r--community/perl-test-yaml/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/community/perl-test-yaml/APKBUILD b/community/perl-test-yaml/APKBUILD
index fa0f0c6f01..f34ee92426 100644
--- a/community/perl-test-yaml/APKBUILD
+++ b/community/perl-test-yaml/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-test-yaml
_pkgreal=Test-YAML
pkgver=1.06
-pkgrel=0
+pkgrel=1
pkgdesc="Testing Module for YAML Implementations"
url="http://search.cpan.org/dist/Test-YAML/"
arch="noarch"
@@ -18,7 +18,7 @@ source="http://search.cpan.org/CPAN/authors/id/I/IN/INGY/$_pkgreal-$pkgver.tar.g
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
@@ -28,7 +28,12 @@ prepare() {
build() {
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
@@ -37,6 +42,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="92e6ea57576428095fe3c9b8e00e6f29 Test-YAML-1.06.tar.gz"
-sha256sums="27376103163c12d7d13ae45bf22caf5a0c38478362425bf68613c3748f76b943 Test-YAML-1.06.tar.gz"
sha512sums="f6fe4bf46a8cc5ea92b5275cc704e79266b11769bd476888b202540a6d9a23a59a2550503afd88a72f9832355e2b48983f6a31f60db07abe5b0e15f4e74ae2e2 Test-YAML-1.06.tar.gz"