aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-time-duration
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2020-03-23 00:45:56 +0000
committerRasmus Thomsen <oss@cogitri.dev>2020-03-23 09:47:46 +0000
commitafb737175f109fcf6f66f401beebaf86ac9ee412 (patch)
tree11e652c712e7d5097449d24bbb8e3c39762f99ab /community/perl-time-duration
parent3dfce151cca61e40995a097fbac40ee723d0f420 (diff)
downloadaports-afb737175f109fcf6f66f401beebaf86ac9ee412.tar.bz2
aports-afb737175f109fcf6f66f401beebaf86ac9ee412.tar.xz
community/perl-time-duration: move from testing and modernize
Diffstat (limited to 'community/perl-time-duration')
-rw-r--r--community/perl-time-duration/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/perl-time-duration/APKBUILD b/community/perl-time-duration/APKBUILD
new file mode 100644
index 0000000000..98f30773cf
--- /dev/null
+++ b/community/perl-time-duration/APKBUILD
@@ -0,0 +1,35 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=perl-time-duration
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=Time-Duration
+pkgver=1.21
+pkgrel=1
+pkgdesc="rounded or exact English expression of durations"
+url="https://metacpan.org/release/Time-Duration/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/N/NE/NEILB/Time-Duration-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="2d03d73096967265f16f4ebde2d9fbb83fce591e15fa01f5f4f750123f27a4571bbd01d5d93f785f78ee8810aca9d945241e6a767b65f45abb4608d321108020 Time-Duration-1.21.tar.gz"