aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-xml-libxml-simple
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 01:16:36 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 01:39:35 +0000
commitb1274f164d3742fc5a47f4ab85a91baef72338ec (patch)
tree7095e084822242b5cff89ac35bb3dee624642067 /community/perl-xml-libxml-simple
parent4c6f8e1fdf89d2899b81dd6a680a65e89e20b7a9 (diff)
downloadaports-b1274f164d3742fc5a47f4ab85a91baef72338ec.tar.bz2
aports-b1274f164d3742fc5a47f4ab85a91baef72338ec.tar.xz
community/perl-[t-y]: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - rename _builddir to builddir
Diffstat (limited to 'community/perl-xml-libxml-simple')
-rw-r--r--community/perl-xml-libxml-simple/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/community/perl-xml-libxml-simple/APKBUILD b/community/perl-xml-libxml-simple/APKBUILD
index ef74c4ffd3..19ce13eacd 100644
--- a/community/perl-xml-libxml-simple/APKBUILD
+++ b/community/perl-xml-libxml-simple/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-xml-libxml-simple
_pkgreal=XML-LibXML-Simple
pkgver=0.97
-pkgrel=0
+pkgrel=1
pkgdesc="XML::LibXML based XML::Simple clone"
url="http://search.cpan.org/dist/XML-LibXML-Simple/"
arch="noarch"
@@ -18,7 +18,7 @@ source="http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/$_pkgreal-$pkgver.tar
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
@@ -28,7 +28,12 @@ prepare() {
build() {
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {