aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-xml-libxslt
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 01:16:36 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 01:39:35 +0000
commitb1274f164d3742fc5a47f4ab85a91baef72338ec (patch)
tree7095e084822242b5cff89ac35bb3dee624642067 /community/perl-xml-libxslt
parent4c6f8e1fdf89d2899b81dd6a680a65e89e20b7a9 (diff)
downloadaports-b1274f164d3742fc5a47f4ab85a91baef72338ec.tar.bz2
aports-b1274f164d3742fc5a47f4ab85a91baef72338ec.tar.xz
community/perl-[t-y]: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - rename _builddir to builddir
Diffstat (limited to 'community/perl-xml-libxslt')
-rw-r--r--community/perl-xml-libxslt/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/community/perl-xml-libxslt/APKBUILD b/community/perl-xml-libxslt/APKBUILD
index 792dbeb6d0..0144a62941 100644
--- a/community/perl-xml-libxslt/APKBUILD
+++ b/community/perl-xml-libxslt/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-xml-libxslt
_pkgreal=XML-LibXSLT
pkgver=1.95
-pkgrel=1
+pkgrel=2
pkgdesc="Interface to GNOME libxslt library"
url="http://search.cpan.org/dist/XML-LibXSLT/"
arch="all"
@@ -16,26 +16,29 @@ makedepends="perl-dev $cpanmakedepends libxml2-dev libxslt-dev libgcrypt-dev lib
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="adf26f5195e18087c89ef3e7f7d97c43 XML-LibXSLT-1.95.tar.gz"
-sha256sums="f1ca21135acc53af9f175958ef5fceb453fd0ef383cfb0e6ef6ea24031f3ef35 XML-LibXSLT-1.95.tar.gz"
sha512sums="06a1c9896a391be2588995f25520da05f086b3fa79109884131525a0d76a7b375e0c5a2febf8a79a888f3a9bd25b5eb39064de1baeffafcfe18f5576c9c54e19 XML-LibXSLT-1.95.tar.gz"