aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-xml-writer
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 09:25:45 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 11:24:37 +0000
commit78901e67c10acee385f9c07b2976e7e3c8ef2023 (patch)
treefbfa4441062763aab3ecd5630aa37b3bbdeb756c /community/perl-xml-writer
parent47da16b5e8c075b9bacd5dfdfdde51e97e73be8d (diff)
downloadaports-78901e67c10acee385f9c07b2976e7e3c8ef2023.tar.bz2
aports-78901e67c10acee385f9c07b2976e7e3c8ef2023.tar.xz
community/perl-xml-writer: moved from testing
Diffstat (limited to 'community/perl-xml-writer')
-rw-r--r--community/perl-xml-writer/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/perl-xml-writer/APKBUILD b/community/perl-xml-writer/APKBUILD
new file mode 100644
index 0000000000..9c30a29293
--- /dev/null
+++ b/community/perl-xml-writer/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer:
+pkgname=perl-xml-writer
+_realname=XML-Writer
+pkgver=0.612
+pkgrel=0
+pkgdesc="Perl extension for writing XML documents"
+url="http://search.cpan.org/~josephw/XML-Writer-0.612/"
+arch="noarch"
+license="PerlArtistic"
+depends="perl"
+depends_dev=""
+makedepends="perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/J/JO/JOSEPHW/$_realname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_realname-$pkgver
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="2f3c6c282f9f79d33639c55bf7afa4b0 XML-Writer-0.612.tar.gz"