aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-yaml/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-10-31 20:26:25 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-10-31 20:26:25 +0000
commit79b485e07232eded37065ebdec2e046c5641bb93 (patch)
tree0b32dd7984d8cc331eea6eaf71e1969eed766d6d /community/perl-yaml/APKBUILD
parent1cdbda37c33de63807c88d5e0999818059d91261 (diff)
downloadaports-79b485e07232eded37065ebdec2e046c5641bb93.tar.bz2
aports-79b485e07232eded37065ebdec2e046c5641bb93.tar.xz
community/perl-yaml: upgrade to 1.24, added check()
Diffstat (limited to 'community/perl-yaml/APKBUILD')
-rw-r--r--community/perl-yaml/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/community/perl-yaml/APKBUILD b/community/perl-yaml/APKBUILD
index 5a1852f09e..354d21aaf9 100644
--- a/community/perl-yaml/APKBUILD
+++ b/community/perl-yaml/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-yaml
_pkgreal=YAML
-pkgver=1.23
+pkgver=1.24
pkgrel=0
pkgdesc="YAML Ain't Markup Language (tm)"
url="http://search.cpan.org/dist/YAML/"
@@ -14,7 +14,7 @@ cpanmakedepends="perl-test-yaml"
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/I/IN/INGY/$_pkgreal-$pkgver.tar.gz"
+source="http://search.cpan.org/CPAN/authors/id/T/TI/TINITA/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
@@ -24,7 +24,12 @@ prepare() {
build() {
cd "$builddir"
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
@@ -33,4 +38,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="42dd2063e16b0e96a51ae9e43ed537741206529ff0df2939717eb142edf6396f69130b6b64d1d338d0c0a32dc11f68f3ffc5e0b5043c325c20e0d492626c106c YAML-1.23.tar.gz"
+sha512sums="20ba196cf9c68a38154f68b884262b9f89463af5e67c1e59944070b2493f6d9515f92a2793f456e20fe7e6372b74da8f6c16b884274793b6c3aa0ed0134c340d YAML-1.24.tar.gz"