aboutsummaryrefslogtreecommitdiffstats
path: root/community/pgexportdoc
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-09 00:32:16 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-10-09 00:32:16 +0200
commit892b84513da1fa92851451adbc703575748bcef3 (patch)
treeeed938fa97a107cc70bc83eeed008a1ac66e2aea /community/pgexportdoc
parenta55ed2043ebe1432fe30400d2aee3b080da32062 (diff)
downloadaports-892b84513da1fa92851451adbc703575748bcef3.tar.bz2
aports-892b84513da1fa92851451adbc703575748bcef3.tar.xz
community/pgexportdoc: move from testing
Diffstat (limited to 'community/pgexportdoc')
-rw-r--r--community/pgexportdoc/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/pgexportdoc/APKBUILD b/community/pgexportdoc/APKBUILD
new file mode 100644
index 0000000000..b30674ebc2
--- /dev/null
+++ b/community/pgexportdoc/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=pgexportdoc
+pkgver=0.1.1
+pkgrel=0
+pkgdesc="CLI tool for export XML, TEXT and BYTEA documents from PostgreSQL"
+url="https://github.com/okbob/pgexportdoc"
+arch="all"
+license="BSD"
+makedepends="libedit-dev libxml2-dev postgresql-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/okbob/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ ./pgexportdoc -V
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="e3589e3a2fe7d77230160711e921908c417e693fd802ee1f803bd2738f38e334d3a3d8df47aa90153c729e6f7f45867c3864909ad609d79b99acfd2e8bf48f55 pgexportdoc-0.1.1.tar.gz"