aboutsummaryrefslogtreecommitdiffstats
path: root/community/phoc/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-03-01 23:46:35 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 01:26:03 -0300
commit9f65be15385811a030998b463fcc26558ab83678 (patch)
tree578918da34cdec22f9b41604e1abc6928a09c556 /community/phoc/APKBUILD
parentc449278221288e24535d7f7426b54b52e602de52 (diff)
downloadaports-9f65be15385811a030998b463fcc26558ab83678.tar.bz2
aports-9f65be15385811a030998b463fcc26558ab83678.tar.xz
community/phoc: move from testing
Diffstat (limited to 'community/phoc/APKBUILD')
-rw-r--r--community/phoc/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/phoc/APKBUILD b/community/phoc/APKBUILD
new file mode 100644
index 0000000000..322cf8fb7c
--- /dev/null
+++ b/community/phoc/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=phoc
+pkgver=0.1.6_git20200126
+pkgrel=1
+pkgdesc="wlroots based Phone compositor for the Phosh shell"
+arch="all !s390x" # no wlroots
+url="https://source.puri.sm/Librem5/phoc"
+license="GPL-3.0-only"
+makedepends="meson ninja gobject-introspection-dev libinput-dev wayland-dev wayland-protocols libxkbcommon-dev wlroots-dev gnome-desktop-dev"
+checkdepends="xvfb-run"
+options="!check" # Needs fullblown EGL
+source="https://source.puri.sm/Librem5/phoc/-/archive/b7e3b683385891558ece51091780a7c54c99ded4/phoc-b7e3b683385891558ece51091780a7c54c99ded4.tar.gz
+ 120.patch"
+builddir="$srcdir/$pkgname-b7e3b683385891558ece51091780a7c54c99ded4"
+
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=plain \
+ . output
+ ninja -C output
+}
+
+check() {
+ xvfb-run ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir/" ninja -C output install
+}
+sha512sums="34693afe087def9e7b4ba62040a1fc6d92f423ad313d76321ec1fe2996d60a608af59bf714d51b21a2a9994dd9698124b55a94c32008313efdf5894d9da37c26 phoc-b7e3b683385891558ece51091780a7c54c99ded4.tar.gz
+175384e1bcb43cd9b97449827e9f88df9c290eaef118c6c18e73d9b94b620074e735e40781f31208a9dd18e7c4af82f310d6f67cb21abfd0919c24c4bd1a2280 120.patch"