aboutsummaryrefslogtreecommitdiffstats
path: root/community/php5-pear-auth_sasl/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-28 13:54:43 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-03-28 18:38:20 +0200
commit4272e802a1be191657becb739e6a248c1d0411a7 (patch)
treea07a25b7c99d7da326957a88173ba49583cf6b2a /community/php5-pear-auth_sasl/APKBUILD
parent3e272105092cd9804a5a022a188db929ebf440da (diff)
downloadaports-4272e802a1be191657becb739e6a248c1d0411a7.tar.bz2
aports-4272e802a1be191657becb739e6a248c1d0411a7.tar.xz
community/*: move php5 and dependent pkgs from main
There two main reasons for this change: * Active support of PHP 5.x ended on January 2017, security support will end on December 2018. Packages in the main repository should be supported for at least 2 years, this means until first quarter of 2019 for the upcoming v3.6. * php7 and its extensions are currently in the community repository, so we can't use single abuild for both php5-* and php7-* packages (as we do for Python and Lua packages). This change was suggested by @vakartel, approved by @ncopa, @kaniini, and @jirutka.
Diffstat (limited to 'community/php5-pear-auth_sasl/APKBUILD')
-rw-r--r--community/php5-pear-auth_sasl/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/php5-pear-auth_sasl/APKBUILD b/community/php5-pear-auth_sasl/APKBUILD
new file mode 100644
index 0000000000..6034bd40e9
--- /dev/null
+++ b/community/php5-pear-auth_sasl/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+_php=php5
+pkgname=${_php}-pear-auth_sasl
+_realname=Auth_SASL
+pkgver=1.0.6
+pkgrel=0
+pkgdesc="Abstraction of various SASL mechanism responses"
+url="http://pear.php.net/package/Auth_SASL"
+arch="noarch"
+license="BSD"
+depends="${_php}-pear"
+makedepends="$depends_dev ${_php}-pear"
+source="http://download.pear.php.net/package/$_realname-$pkgver.tgz"
+builddir="$srcdir"/$_realname-$pkgver
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$builddir"
+
+ mkdir -p "$pkgdir"/usr/share/pear && \
+ cp -R Auth "$pkgdir"/usr/share/pear || return 1
+}
+
+
+md5sums="8ac4a0b7be08998ef1e10741cb5114f9 Auth_SASL-1.0.6.tgz"
+sha256sums="9bea8864466170de6cb2e397b938a585f3d18342dbe052d9f839460df8155ccc Auth_SASL-1.0.6.tgz"
+sha512sums="e2ff9511bf0aadbd1ce054e67b222f2430e31bc81639d18292a22000ca3f88323d14d6110bdf0fb1ae3101b751881550165bda7b896852248d719b1d111347f3 Auth_SASL-1.0.6.tgz"