aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-pecl-timezonedb/APKBUILD
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2019-04-02 20:00:31 +0300
committerAndy Postnikov <apostnikov@gmail.com>2019-04-03 16:10:02 +0300
commitb4709c773b77e3164d8e162b3e23163451722c73 (patch)
tree103b7f27323f370741e9c44d3ad1ce88e99ccc54 /community/php7-pecl-timezonedb/APKBUILD
parentf41a347c5cdc1034631c006f432ae8f03108a2f1 (diff)
downloadaports-b4709c773b77e3164d8e162b3e23163451722c73.tar.bz2
aports-b4709c773b77e3164d8e162b3e23163451722c73.tar.xz
community/php7-pecl-timezonedb: add check()
Diffstat (limited to 'community/php7-pecl-timezonedb/APKBUILD')
-rw-r--r--community/php7-pecl-timezonedb/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/community/php7-pecl-timezonedb/APKBUILD b/community/php7-pecl-timezonedb/APKBUILD
index e852504597..8794a2d8c4 100644
--- a/community/php7-pecl-timezonedb/APKBUILD
+++ b/community/php7-pecl-timezonedb/APKBUILD
@@ -3,7 +3,7 @@
pkgname=php7-pecl-timezonedb
_pkgreal=timezonedb
pkgver=2019.1
-pkgrel=0
+pkgrel=1
pkgdesc="Timezone Database to be used with PHP's date and time functions."
url="https://pecl.php.net/package/timezonedb"
arch="all"
@@ -12,7 +12,6 @@ depends="php7-common"
makedepends="php7-dev autoconf re2c"
source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
builddir="$srcdir/$_pkgreal-$pkgver"
-options="!check" # upstream does not provide tests yet
provides="php7-timezonedb=$pkgver-r$pkgrel" # for backward compatibility
replaces="php7-timezonedb" # for backward compatibility
@@ -23,6 +22,11 @@ build() {
make
}
+check() {
+ # Test suite is not a part of pecl release.
+ php7 -d extension="$builddir"/modules/$_pkgreal.so --ri $_pkgreal
+}
+
package() {
cd "$builddir"
make INSTALL_ROOT="$pkgdir"/ install