aboutsummaryrefslogtreecommitdiffstats
path: root/community/picom
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-12-30 14:54:12 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-07 10:13:47 +0100
commit78d37d9942be8548da47259a8b0f5ea584ed1f16 (patch)
treec071a4c1c2581c76002b213923520dff8a2f90d1 /community/picom
parent92116a4678aa9557f35ec994424bb86ce1e21626 (diff)
downloadaports-78d37d9942be8548da47259a8b0f5ea584ed1f16.tar.bz2
aports-78d37d9942be8548da47259a8b0f5ea584ed1f16.tar.xz
tree-wide: use --buildtype=debugoptimized for meson packages
As of now we're using the buildttype 'release', which produces optimized builds but without any usable debugging info, which makes debugging crashes impossible, even if a -dbg subpackage exists. As such we should build in the buildmode 'debugoptimized' to offer proper debug symbols.
Diffstat (limited to 'community/picom')
-rw-r--r--community/picom/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/picom/APKBUILD b/community/picom/APKBUILD
index 2c7ec81a62..501368b8a2 100644
--- a/community/picom/APKBUILD
+++ b/community/picom/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=picom
pkgver=7.5
-pkgrel=0
+pkgrel=1
pkgdesc="X Compositor (a fork of compton)"
url="https://github.com/yshui/picom"
arch="all"
@@ -19,7 +19,7 @@ replaces="compton" # Backwards compatibility
provides="compton=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- meson --prefix=/usr --buildtype=release -Dbuild_docs=true build
+ meson --prefix=/usr --buildtype=debugoptimized -Dbuild_docs=true build
ninja -v -C build
}