aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-applet-weather-widget/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-06 14:19:02 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-10-31 22:30:59 +0000
commitf0facd72e7b92c64f07d5536b127680a5e8f2f56 (patch)
tree58de8dfd8599b558e8a1bc2515c2912571e08645 /community/plasma-applet-weather-widget/APKBUILD
parent0eb736e238ab40b177dc15174b1d2fe0cee75a05 (diff)
downloadaports-f0facd72e7b92c64f07d5536b127680a5e8f2f56.tar.bz2
aports-f0facd72e7b92c64f07d5536b127680a5e8f2f56.tar.xz
community/plasma-applet-weather-widget: move from testing
Diffstat (limited to 'community/plasma-applet-weather-widget/APKBUILD')
-rw-r--r--community/plasma-applet-weather-widget/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/plasma-applet-weather-widget/APKBUILD b/community/plasma-applet-weather-widget/APKBUILD
new file mode 100644
index 0000000000..28f7fde490
--- /dev/null
+++ b/community/plasma-applet-weather-widget/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=plasma-applet-weather-widget
+pkgver=1.6.10
+pkgrel=2
+arch="all"
+url="https://www.linux-apps.com/content/show.php/Weather+Widget?content=169572"
+pkgdesc="Plasmoid for showing weather information from yr.no and Open Weather Map servers"
+license="GPL-2.0-only"
+depends="qt5-qtxmlpatterns qt5-qtdeclarative"
+makedepends="extra-cmake-modules qt5-qtbase-dev plasma-framework-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/kotelnik/plasma-applet-weather-widget/archive/v$pkgver.tar.gz"
+subpackages="$pkgname-lang"
+options="!check" # No tests
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="5db4c2e426b9b8296b70ec4edf5fc2dbc5e8056f66327569008a77b05201896ed23039aae063807726376e203d637053884bfeeac78c59c519b7fc5685797331 plasma-applet-weather-widget-1.6.10.tar.gz"