aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-browser-integration
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-09 21:32:43 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-11 15:14:34 -0300
commit8a42cdc9bb9527a23da8ce6a268dffd0890cefcc (patch)
tree977a155542c7515ca6f468beaeb4e14d60a489ba /community/plasma-browser-integration
parent3bbde52d44a77dde04d6db158fba61ee9d9f1e9a (diff)
downloadaports-8a42cdc9bb9527a23da8ce6a268dffd0890cefcc.tar.bz2
aports-8a42cdc9bb9527a23da8ce6a268dffd0890cefcc.tar.xz
community/plasma-browser-integration: move from testing
Diffstat (limited to 'community/plasma-browser-integration')
-rw-r--r--community/plasma-browser-integration/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/plasma-browser-integration/APKBUILD b/community/plasma-browser-integration/APKBUILD
new file mode 100644
index 0000000000..8e9e3bc55f
--- /dev/null
+++ b/community/plasma-browser-integration/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=plasma-browser-integration
+pkgver=5.16.5
+pkgrel=0
+pkgdesc="Components necessary to integrate browsers into the Plasma Desktop"
+arch="all"
+url="https://community.kde.org/Plasma/Browser_Integration"
+license="GPL-3.0-or-later"
+makedepends="extra-cmake-modules qt5-qtbase-dev kio-dev ki18n-dev kconfig-dev kdbusaddons-dev knotifications-dev krunner-dev kactivities-dev"
+source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="667c5ef2dd0529e6c567e9d3e34e8e6df73e0101605ccc4a6712e7f47b6824407495102ddc9b800e411f53a1fdf0132caebf6d955c39e7a80b7ab6569d02d1b4 plasma-browser-integration-5.16.5.tar.xz"