aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-pa
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-09 21:34:55 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-11 15:14:34 -0300
commit5dde3f3c364d1613b603d35eae3d4a0842956029 (patch)
treec1cf9594aeeda9e1482cbfe9781e9b7d447ee8d5 /community/plasma-pa
parent46cb1a5175fe143351e3965aa2ba204ddbd3c74b (diff)
downloadaports-5dde3f3c364d1613b603d35eae3d4a0842956029.tar.bz2
aports-5dde3f3c364d1613b603d35eae3d4a0842956029.tar.xz
community/plasma-pa: move from testing
Diffstat (limited to 'community/plasma-pa')
-rw-r--r--community/plasma-pa/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/plasma-pa/APKBUILD b/community/plasma-pa/APKBUILD
new file mode 100644
index 0000000000..3c2f49e063
--- /dev/null
+++ b/community/plasma-pa/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=plasma-pa
+pkgver=5.16.5
+pkgrel=0
+pkgdesc="Plasma applet for audio volume management using PulseAudio"
+arch="all !ppc64le !s390x" # Limited by plasma-workspace -> libksysguard -> qt5-qtwebengine
+url="https://www.kde.org/workspaces/plasmadesktop/"
+license="LGPL-2.1-only OR LGPL-3.0-only AND GPL-2.0-only"
+depends="pulseaudio kirigami2"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev kcoreaddons-dev kdeclarative-dev kdoctools-dev kglobalaccel-dev knotifications-dev ki18n-dev plasma-workspace-dev pulseaudio-dev libcanberra-dev"
+source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DUSE_GCONF=OFF
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="393cc05b8999b10213fd608863d16f14c3d38fe8d82b01a1869bb37a4c8ce4d023deaac11a12a087f79bea5ffca9ff4e3dd846fd2ba195df8513e9ea8d3a8618 plasma-pa-5.16.5.tar.xz"