aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-sdk
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-09 21:35:07 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-11 15:14:34 -0300
commite8c8f620c79f06222bb8cd2b4fb616b1c2c273b8 (patch)
tree41b4608744fee7ac40f560baa01d3bb39bd7cde5 /community/plasma-sdk
parent5dde3f3c364d1613b603d35eae3d4a0842956029 (diff)
downloadaports-e8c8f620c79f06222bb8cd2b4fb616b1c2c273b8.tar.bz2
aports-e8c8f620c79f06222bb8cd2b4fb616b1c2c273b8.tar.xz
community/plasma-sdk: move from testing
Diffstat (limited to 'community/plasma-sdk')
-rw-r--r--community/plasma-sdk/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/plasma-sdk/APKBUILD b/community/plasma-sdk/APKBUILD
new file mode 100644
index 0000000000..3fb04fa0fc
--- /dev/null
+++ b/community/plasma-sdk/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=plasma-sdk
+pkgver=5.16.5
+pkgrel=0
+pkgdesc="Applications useful for Plasma Development"
+arch="all"
+url="https://www.kde.org/workspaces/plasmadesktop/"
+license="GPL-2.0-or-later"
+depends="kirigami2"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtsvg-dev karchive-dev kcompletion-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev kdbusaddons-dev kdeclarative-dev ki18n-dev kiconthemes-dev kio-dev plasma-framework-dev kservice-dev ktexteditor-dev kwidgetsaddons-dev kdoctools-dev kparts-dev"
+checkdepends="xvfb-run"
+source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
+build() {
+ cd "$builddir"/build
+ cmake "$builddir" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ cd "$builddir"/build
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+}
+
+package() {
+ cd "$builddir"/build
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="95ed00eebe787ec36d68f47e01f717cb5929c7c15c89b33be5b8edac7c9c4d700af6b81c6353e1b5bc783360f542b8284b78706f4c4de398d10db1bcaf23e4fe plasma-sdk-5.16.5.tar.xz"